拓冰建站拓冰建站
首页 / 资讯中心 / 正文

解决在docker中部署的jenkins使用`withDockerContainer` 报错问题 Cannot run program “docker“: Exec failed

执行如下命令ls -l /usr/bin/dockerls: cannot access /usr/bin/docker: No such file or directory根因withDockerContainer是docker-workflow插件本质是在节点上调用本地docker二进制执行命令重新创建镜像将主机的docker路径挂载到jenkins容器中services: myjenkins: image: jenkins/jenkins:2.583 # 容器名字 container_name: myjenkins restart: always user: root ports: - 8080:8080 - 50000:50000 volumes: # 沿用原有持久卷数据不丢失 - jenkins-data:/var/jenkins_home # 支持容器内调用docker - /var/run/docker.sock:/var/run/docker.sock # 新增下面的挂载解决找不到docker路径问题 /usr/bin/docker - /usr/bin/docker:/usr/bin/docker environment: - TZAsia/Shanghai # 入口脚本先修改时区软链接再启动jenkins不生效还在找原因中 # entrypoint: [/bin/bash, -c, ln -sf /usr/share/zoneinfo/Asia/Shanghai /etc/localtime exec /usr/local/bin/jenkins.sh] volumes: jenkins-data:
分享:

看完干货,该让你的企业上线了

免费需求沟通 · 48 小时内出具建站方案 · 河南本地可上门